Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

unable to disable config tracking for different servers

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.6.5
  • Fix Version/s: 4.6.5
  • Component/s: Deprecated: Frantic
  • Environment:
    linux with weblogic, windows with websphere
  • Case Links:
    none
  • HQ Fix Version:
    4.6.5
  • Regression:
    No

Description

when trying to disable the config tracking funcationality from a specific resource, unchecking the "server.config_track.enable" in the resource Configuration Properties succeeds. but it looks like it does not affect anything - the "server.config_track.enable" value does not change to "False" afterwards and configuration changes keeps being tracked.

this was seen on both windows and linux plugins. no indication for such failure in the agent/server logs.

Activity

Guy Segev added a comment -

Issue was with unchecked checkboxes which were missing from the http request (by design).
Added explicit support for false values for boolean config options.

yael twina (c) added a comment -

works good in verssion 4.6.5.BUILD-SNAPSHOT-2012-02-08.
i change "unable" to "disable" in some plugins checkboxes (server.log_track.enable etc...) and it was changed to false.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 9 weeks, 5 days ago