Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Oracle upgrade fails from 4.5.2.2 to 4.6.5

Details

  • Type: Developer Developer
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.6.5
  • Fix Version/s: 4.6.5
  • Component/s: Deprecated: Installer
  • Environment:
    Platfrom : Linux , Version : 4.5.2.2.-GA and 4.6.5.BUILD-20120131.093802-29 ,DB :Oracle
  • Case Links:
    none
  • Regression:
    No

Description

Steps to Reproduce

Upgrade from 4.5.2.2 to 4.6.5 (hyperic-hqee-installer-4.6.5.BUILD-20120131.093802-29-x86-linux.tar.gz)

Actual Results:

/opt/hyperic/465/29-0131/hyperic-hqee-installer-4.6.5.BUILD-SNAPSHOT/installer/data/db-upgrade.xml:43: DBUpgrader: Error running SchemaSpec: 3.208: Error running SchemaSpecTask: org.hyperic.tools.ant.dbupgrade.SST_DirectSQL: Error executing statement desc=[null] SQL=[
create table EAM_KEYSTORE (
ID number(10,0) not null,
ALIAS_NAME varchar2(128 char) not null,
TYPE varchar2(32 char) not null,
CERT varchar2(4000 char) not null,
CERT_CHAIN varchar2(4000 char),
FILE BLOB,
primary key (ID),
unique (ALIAS_NAME)
)
] java.sql.SQLException: ORA-00904: : invalid identifier
--------------------------------------------------------------------------------
Deleting temporary JRE

Expected Results:

Should work fine

  1. hq-install.log
    31/Jan/12 4:45 PM
    24 kB
    Nipuna Bhayani
  2. hq-install.log.verbose
    31/Jan/12 4:45 PM
    3.98 MB
    Nipuna Bhayani

Activity

Guy Segev added a comment -

Enclosed the oracle FILE column declaration in double quotes

Ryan Morgan added a comment -

A couple things on this commit:

1) We shouldn't need to clutter our db-upgrade.xml with stuff like this since this table was introduced in 4.6.5. The only benefit of doing so is continuity for upgrades of previous 4.6.5 snapshot builds. I'd recommend we change the original db-upgrade CREATE statement in 3.208 to be correct to start and remove version 3.210

2) TYPE is also a reserved keyword in Oracle. I'm surprised it's allowing you to create a column with that name without quoting the value. http://docs.oracle.com/cd/B19306_01/em.102/b40103/app_oracle_reserved_words.htm. TYPE is also a non-reserved keyword in Postgres.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 10 weeks, 5 days ago