Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Can't upload .jar plugin when hyperic server is on windows

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.6.0.1
  • Fix Version/s: 4.6.5
  • Environment:
    WinXP
    Builtin DB
  • Case Links:
    none
  • HQ Fix Version:
    4.6.5 Build from Feb 09
  • Regression:
    No

Description

If Hyperic Server is running on windows. The Plugin Manager UI doesn't successfully upload plugins

  • .jar plugins are claimed to be uploaded successfully. However, they are not. No error in server.log even with DEBUG logging.
  • .jar plugins which include other plugins fail with same issue as HHQ-5399

Steps to reproduce:

1.) Setup 4.6.0.1 Server and Agent
2.) Remove memcache-plugin and zimbra-plugin from server (but keep backup for next steps)
3.) Now try to upload zimbra-plugin (includes another). Same error as reported in HHQ-5399
4.) Now try to upload memcache-plugin (which has no includes). No error. Server reports success. Nothing in server.log with PluginManagerImpl set to DEBUG logging.

Expected Results:

Plugins Successfully deployed

Workaround:

  • Manually deploy plugins to hq-plugins directory on server

Activity

Maya Anderson added a comment -

zimbra error is solved by HHQ-5399.
Jar upload on Windows used to fail because of an unsuccessful move of the Jar from a temp folder into the plugins folder.

rivka pints (c) added a comment -

Verified in Version 4.6.5.BUILD-SNAPSHOT-2012-02-08
success to upload the plugin.jar an plugin.xml files to Hyperic server on win xp platform.
validate that the plugin file exist in the Hq-plugins folder and agents automatically synchronize success.


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    2 years, 9 weeks, 3 days ago