Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Unable to use special characters / < > & * ? % in resource names in UI

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 4.6.5
  • Fix Version/s: 4.6.6
  • Component/s: Deprecated: UI
  • Case Links:
  • Regression:
    Yes

Description

Similar to HHQ-5494 the changes in [HQ-1892] prevent creating or editing a resource name if it contains special characters such as / < > & * ? %

This is extremely unrealistic since we auto discover resources with / in them. Such as "Apache Tomcat 6.0 Servlet Monitor" services discovered on hyperic's HQ Tomcat. They are discovered as names such as "HQ Tomcat 6.0 Resources Servlet none none //localhost/tomcatserverconfig Servlet Monitor". These are not editable. This is just an example. Customers may also have created resources that are the names of URLs such as "http://localhost:7080" which would now be unable to edit in the UI.

Further more the restriction only applies to the UI which fortunately provides a workaround by using hqapi or other tools which access the internal APIs directly.

Activity

rivka pints (c) added a comment -

verified on 4.6.6.BUILD-20120520.132831-11


People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 48 weeks, 3 days ago