Support Migration Notice: To update migrated JIRA cases click here to open a new case use www.vmware.com/go/sr | vFabric Hyperic 5.7.0 is Now Available

Hyperic HQ

Agent won't start when custom private key used

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Blocker Blocker
  • Resolution: Fixed
  • Affects Version/s: 4.6.6, 5.0
  • Fix Version/s: 4.6.6.1
  • Component/s: Deprecated: Agent:Core
  • Environment:
    Any agent with custom private key named other than "hq"
  • Importance:
    1-Very High
  • Case Links:
  • HQ Fix Version:
    4.6.6
  • Regression:
    Yes

Description

Symptoms:

Agent won't start when using a custom private key that isn't named "hq"

Steps to Reproduce:

1.) Install 4.6.6 agent
2.) Configure private key in keystore with an alias other than "hq" (keystore should not have a key named "hq")
3.) Set agent.keystore.alias in agent.properties to the name of the private key (optional per docs. Only required for unidirectional communications)
4.) Try to start agent

Actual Results:

Agent won't start. The following exception:

17-06-2012 20:17:15,966 SGT ERROR [AgentDaemonMain] [AgentDaemon@1004] Agent configuration failed:
java.lang.NullPointerException
at org.hyperic.hq.agent.server.AgentDListProvider.getKeyvalsPass(AgentDListProvider.java:228)
at org.hyperic.hq.agent.server.AgentDListProvider.flush(AgentDListProvider.java:250)
at org.hyperic.hq.agent.server.AgentDaemon.configure(AgentDaemon.java:500)
at org.hyperic.hq.agent.server.AgentDaemon.newInstance(AgentDaemon.java:184)
at org.hyperic.hq.agent.server.AgentDaemon$RunnableAgent.run(AgentDaemon.java:1001)
at java.lang.Thread.run(Thread.java:662)

Expected Results:

Agent successfully starting

  1. agent.log
    20/Jun/12 3:10 PM
    3.04 MB
    Nipuna Bhayani
  2. agent.log.startup
    20/Jun/12 3:10 PM
    0.9 kB
    Nipuna Bhayani
  3. wrapper.log
    20/Jun/12 3:10 PM
    6 kB
    Nipuna Bhayani

Activity

Wes Schlichter added a comment - - edited

Root cause appears to be that AgentDListProvider hard codes the key name to "hq" instead of looking at the value of agent.keystore.alias property. In addition the private key has not been required for the agent to run unless in unidirectional mode

Wes Schlichter added a comment -

Any fix needs to take into consideration that agent.keystore.alias is optional and that in 4.6.0.x, 4.6.5, and 4.6.6 that customers with a custom keystore may not have a private key for the agent since it isn't required unless unidirectional communication is used. Suddenly requiring this for large environments will not be considered feasible.

Guy Segev added a comment -

Also linked to SUPPORT-12015

Melanie Spatola added a comment -

I sent Mayan an e-mail about this one, please confirm what the fix is for this issue. The last comment doesn't give a work around or explanation that it is fixed, in the same version that the bug was found in. Thanks in advance and let us know if you need anything specific from support to assist with investigating this further.

Mayan Weiss added a comment -

this was mistakenly reopened


People

Vote (0)
Watch (6)

Dates

  • Created:
    Updated:
    Resolved:
    Last comment:
    1 year, 41 weeks, 4 days ago